Unsupported Browser

I was searching for an image today and got the following page after clicking on the link:

Unsupported Browser

The browser you are using (Opera/9.80 (Windows NT 5.0; U; en) Presto/2.5.22 Version/10.51) is currently unsupported. Please update your browser to the most current level.

Updates for Internet Explorer

Updates for Netscape Navigator

These folks need to move into the 21st century. There are other browsers other than Internet Explorer. Netscape? Get real. It didn’t even identify my browser correctly. Update my browser to the most current level? I’ve got news for you. I’m well past version 9.80 for Opera. The link did work in Firefox which it sees as Netscape (Gecko engine). That’s good because IE doesn’t work on my main computer. I’m not really in a hurry to “fix” it.

Advertisements

Author: Rick

I'm a simple man, trying to make my way in the universe.